Social Icons

banner image

HACKRANKER CHALLENGE : java end of line


Java End-of-file


"In computing, End Of File (commonly abbreviated EOF) is a condition in a computer operating system where no more data can be read from a data source." — (Wikipedia: End-of-file)
The challenge here is to read n lines of input until you reach EOF, then number and print all n lines of content.
Hint: Java's Scanner.hasNext() method is helpful for this problem.
Input Format
Read some unknown n lines of input from stdin(System.in) until you reach EOF; each line of input contains a non-empty String.
Output Format
For each line, print the line number, followed by a single space, and then the line content received as input:
k This is the line read as input for line number 'k'.
Sample Input
Hello world
I am a file
Read me until end-of-file.
Sample Output
1 Hello world
2 I am a file
3 Read me until end-of-file.
solution:
import java.io.*;
import java.util.*;
import java.text.*;
import java.math.*;
import java.util.regex.*;

public class Solution {

    public static void main(String[] args) {
        Scanner scan = new Scanner(System.in);
        int lineNumber= 1;
        while(scan.hasNext())
        { 
            String readLine = scan.nextLine(); 
            System.out.println(lineNumber + " "+ readLine); 
            lineNumber++; 
      
    }
}
}
HACKRANKER CHALLENGE : java end of line HACKRANKER CHALLENGE : java end of line Reviewed by Shobhit Goel on April 19, 2016 Rating: 5

No comments:

Airtel Hackaton 2017

Powered by Blogger.